HOME > 게시판 > 리눅스
게시판| 리눅스
※ 게시판 용도에 맞지 않는 글(광고및 홍보 글 등)은 임의삭제될 수 있습니다.

 
작성일 : 14-04-01 13:54
코덱 때문에 플러그인을 까는 도중에 에러가 발생했습니다.
 글쓴이 : PHmaruho
조회 : 1,166  
[root@localhost yum ~] # yum -y install gstreamer-plugins-bad gstreamer-plugins-ugly xine-lib-extras-nonfree gstreamer-ffmpeg
Loaded plugins: fastestmirror, langpacks, refresh-packagekit
adobe-linux-x86_64                                       |  951 B     00:00     
livna                                                    | 1.3 kB     00:00     
rpmfusion-free-rawhide                                   | 3.3 kB     00:00     
rpmfusion-nonfree-rawhide                                | 3.3 kB     00:00     
updates/20/x86_64/metalink                               | 5.8 kB     00:00     
updates                                                  | 4.9 kB     00:00     
updates/20/x86_64/primary_db                               | 8.9 MB   00:01     
(1/3): updates/20/x86_64/updateinfo                        | 931 kB   00:00     
(2/3): updates/20/x86_64/pkgtags                           | 1.0 MB   00:00     
(3/3): rpmfusion-free-rawhide/x86_64/primary_db            | 417 kB   00:02     
Loading mirror speeds from cached hostfile
 * fedora: ftp.neowiz.com
 * livna: wftp.tu-chemnitz.de
 * rpmfusion-free-rawhide: mirror.switch.ch
 * rpmfusion-nonfree-rawhide: mirrors.hustunique.com
 * updates: ftp.kaist.ac.kr
Package gstreamer-plugins-bad-0.10.23-5.fc21.x86_64 already installed and latest version
No package xine-lib-extras-nonfree available.
Package gstreamer-ffmpeg-0.10.13-11.fc21.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package gstreamer-plugins-ugly.x86_64 0:0.10.19-14.fc20 will be updated
---> Package gstreamer-plugins-ugly.x86_64 0:0.10.19-17.fc21 will be an update
--> Processing Dependency: libcdio.so.15(CDIO_15)(64bit) for package: gstreamer-plugins-ugly-0.10.19-17.fc21.x86_64
--> Processing Dependency: libx264.so.142()(64bit) for package: gstreamer-plugins-ugly-0.10.19-17.fc21.x86_64
--> Running transaction check
---> Package gstreamer-plugins-ugly.x86_64 0:0.10.19-17.fc21 will be an update
--> Processing Dependency: libcdio.so.15(CDIO_15)(64bit) for package: gstreamer-plugins-ugly-0.10.19-17.fc21.x86_64
---> Package x264-libs.x86_64 0:0.138-2.20131030gitc628e3b.fc20 will be updated
--> Processing Dependency: libx264.so.138()(64bit) for package: gstreamer1-plugins-ugly-1.2.3-1.fc20.x86_64
---> Package x264-libs.x86_64 0:0.142-3.20140314gitaff928d.fc21 will be an update
--> Running transaction check
---> Package gstreamer-plugins-ugly.x86_64 0:0.10.19-17.fc21 will be an update
--> Processing Dependency: libcdio.so.15(CDIO_15)(64bit) for package: gstreamer-plugins-ugly-0.10.19-17.fc21.x86_64
---> Package gstreamer1-plugins-ugly.x86_64 0:1.2.3-1.fc20 will be updated
---> Package gstreamer1-plugins-ugly.x86_64 0:1.2.3-3.fc21 will be an update
--> Processing Dependency: libcdio.so.15(CDIO_15)(64bit) for package: gstreamer1-plugins-ugly-1.2.3-3.fc21.x86_64
--> Finished Dependency Resolution
Error: Package: gstreamer1-plugins-ugly-1.2.3-3.fc21.x86_64 (rpmfusion-free-rawhide)
           Requires: libcdio.so.15(CDIO_15)(64bit)
Error: Package: gstreamer-plugins-ugly-0.10.19-17.fc21.x86_64 (rpmfusion-free-rawhide)
           Requires: libcdio.so.15(CDIO_15)(64bit)

 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

마지막에 굵은 글씨의 에러가 발생했습니다.
Requires 구문의 libcdio.so.15(CDIO_15)(64bit)를 찾아 설치하면 또 에러가 발생합니다

이 글을 트위터로 보내기 이 글을 페이스북으로 보내기

PHmaruho 14-04-01 13:59
 
수정을 못했는데 운영체제는 페도라 20 입니다