HOME > 게시판 > 자유게시판
게시판| 자유게시판
※ 게시판 용도에 맞지 않는 글(광고및 홍보 글 등)은 임의삭제될 수 있습니다.

 
작성일 : 07-01-31 17:23
SuSE 부트로더 관련 질문입니다. 봐주세요.ㅠ
 글쓴이 : 강현규
조회 : 1,985  

안녕하세요. 이번에 새로 릴리즈된 SuSE 10.2  를 OS로 쓰려고

설치하는 도중 문제가 발생하였습니다.

먼저, 시스템은 하드가 5개 달려있는데요,

이중에 2개 (각각 7.8GB, 320GB) 는 피시 메인 보드에, 그리고 나머지

3개(156GB*3)는 RAID로 묶어놓았습니다.

7.8GB의 하드가 마스터로 잡혀 있고, 320GB의 하드가

슬레이브로 잡혀있습니다. 물론 하드의 데이터는 모두

비워져있는 상태구요. (이전에 Red Hat 9.0 설치후 포맷했습니다.

fdisk /mbr 및 포맷 후 fdisk 로 마스터 영역 삭제했습니다.)

그래서 7.8GB의 하드에 SuSE 를 설치하는데,

5번 시디까지 모두 설치 된 후, 부트로더 설치에서

오류가 발생합니다. 그 메세지는

 

GNU / GRUB version 0.97 (640K lower / 3072K upper memory)

[Minimal BASH-like line editing is supported. For the first word. TAB

lists possible command competions. Anywhere else TAB lists the possible

completions of a device/filename.]

grub> setup --stage2=/boot/grub/stage2 (hd0) (/dev/hda.0)

 

Error 23 : Error while parsing number

grub>  quit

 

여기서 확인 누르면

"부트로더가 제대로 설치되지 않았습니다.

부트로더 설정을 다시 확인하세요"

라는 메세지가 뜨고 "예"를 클릭하면 설정 화면으로,

"아니오"를 클릭하면 그냥 넘어가버리고 재부팅시

시스템이 제대로 작동하지 않습니다.ㅠ

고쳐볼려고 온갖 방법을 다 동원했지만 실패했습니다.ㅠ

혹, 해결방법을 아신다면 무엇이든 다 적어주세요.

부탁드릴게요~~


이 글을 트위터로 보내기 이 글을 페이스북으로 보내기

서성헌 09-04-13 14:51
 
/boot/grub/device.map에서 (hd0) 가 잘못 잡혀있어서 그럴 수 있습니다. 부팅설정에서 (hd0)를 올바른 장치명으로 바꾸줘보십시요. 올바른 장치명은 menu.lst 파일에서 root=xxx 에 써져 있으므로, 장치명을 복사해서 devece.map으로 붙여넣기 하시면 됩니다. 장치명이 xxx-part2 와 같이 되어있을 때는 뒤의 -part2는 파티션 넘버이므로 빼고 붙여넣기 하셔야 합니다.
난다황 07-02-01 15:24
 
설정된 /boot/grub/grub.conf 파일의 디스크가 설치된후 바뀐경우에 이런 식이 되기도 합니다. 설정에서 root=/dev 이부분을 바꿔보세요