질문&답변
클라우드/리눅스에 관한 질문과 답변을 주고 받는 곳입니다.
리눅스 분류

Centos 6.7 내부망 rpm 설치 질문입니다.

작성자 정보

  • 나나타찬 작성
  • 작성일

컨텐츠 정보

본문

궁금한게 있어서 여쭤봅니다

환경은 Centso 6.7 , 커널 2.6.32-573.18.1.el6.x86_64 내부망인데요

php-odbc-5.3.3-47.el6.x86_64.rpm

php-5.3.3-47.el6.x86_64.rpm

패키지를 설치하려다보니

error: Failed dependencies:

        httpd is needed by php-5.3.3-47.el6.x86_64

        httpd-mmn = 20051115 is needed by php-5.3.3-47.el6.x86_64

        php-cli(x86-64) = 5.3.3-47.el6 is needed by php-5.3.3-47.el6.x86_64

        php-common(x86-64) = 5.3.3-47.el6 is needed by php-5.3.3-47.el6.x86_64 메세지가 뜨면서 의존성때문에 설치가 안된다고 합니다.

무시하고 --nodeps 나 --force 는 권한 문제로 불가하고

yum localinstall도 내부망 문제로 안되면

의존성 걸린 패키지 전부 설치하고 패키지 설치 진행하는 방법 밖에는 없나요?

답변 부탁드립니다.


관련자료

댓글 1

dslee님의 댓글

  • dslee
  • 작성일
선행으로 설치되어야할 것들이 설치되어야만 원하시는 답을 찾을수 있을거 같네요. 당순히
--nodeps 나 --force 등으로 무시해서 설치한다고 답을 찾을수 있지는 않을거 같습니다.

공지사항


뉴스광장


  • 현재 회원수 :  60,066 명
  • 현재 강좌수 :  35,971 개
  • 현재 접속자 :  234 명