질문&답변
클라우드/리눅스에 관한 질문과 답변을 주고 받는 곳입니다.
리눅스 분류

CentOS 재설치 방법? 64비트 CentOS에서 i386 라이브러리 사용?

작성자 정보

  • 자연 작성
  • 작성일

컨텐츠 정보

본문

지금 서버에 설치된 CentOS 버전은 
# lsb_release -a
LSB Version:    :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID: n/a
Description:    redhat-4
Release:        n/a
Codename:       n/a

# dmesg |more
Initializing cgroup subsys cpuset
Initializing cgroup subsys cpu
Linux version 2.6.32-358.el6.x86_64 (mockbuild@c6b8.bsys.dev.centos.org) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-3) (GCC
) ) #1 SMP Fri Feb 22 00:31:26 UTC 2013
Command line: ro root=UUID=b224e229-bd8f-4aca-beaf-7f63614fdc50 rd_NO_LUKS LANG=ko_KR.UTF-8 rd_NO_MD crashkernel=128M  KEYB
OARDTYPE=pc KEYTABLE=us rd_NO_LVM rd_NO_DM rhgb quiet
....

인데, 이렇다면, 이것은 CentOS 6.6 (x86_64) 으로 보는 것이 맞는 지요? 
--> 초기화면 로고를 보니까 "CentOS 6 " 으로 나오는데 그럼 CentOS 6.6일까요?


여기에 오라클10g(오라클 10.2.0  -->  10201_database_linux_x86_64.cpio)을 설치하다가 문제가 발생해서 
기존에 오라클이 설치된 다른 CentOS서버와 비교를 해 보았는데, 
libgcj 패키지가버전이 다른 것이 문제라고 생각하게 되었습니다.
즉, 오라클이 정상 설치된 다른 CentOS 5 서버는, OS 자체는 64비트 버전인데, 
libgcj 패키지가 i386으로 되어 있더라고요.
# yum info libgcj
Loaded plugins: fastestmirror
Installed Packages
Name       : libgcj
Arch       : i386
Version    : 4.1.2
Release    : 50.el5

...

반면, 제가 새로 오라클10g를 깔려고 하는 CentOS 서버에는 64비트 버전의 libgcj가  깔려 있고요.
[pjmics-web:/home/oracle] yum info libgcj
Loaded plugins: fastestmirror, refresh-packagekit, security
Installed Packages
Name        : libgcj
Arch        : x86_64
Version     : 4.4.7
Release     : 3.el6
...


이런 상황에서 오라클 10G(10201_database_linux_x86_64.cpio)로 설치하면서 에러나는 부분을 보니, 
오라클10g 패키지 안에, i386 아키텍처를 갖는 라이브러리(libawt.so)가 있더라고요.
이게 설치 시점에서 에러를 발생시키는 부분이고요.
[/tmp/OraInstall2014-11-20_03-26-43PM/jre/1.4.2/lib/i386] objdump -a libawt.so
libawt.so:     file format elf32-i386


이런상황으로 봐서, 
libgcj 를 i386 버전으로 재설치 해야 겠다고 생각하고, 
새로 오라클10g를 깔려고 하는 CentOS서버에서 libgcj 패키지를 지웠습니다.
# yum remove libgcj

지운다보니, Dependency 가 있는 88개나 되는 패키지도 같이 지우게 되었습니다.

이렇게 지우고 보니, 아차 싶더군요.


상황설명이 장황했고요, 
결론적인 질문은 이렇습니다.

이런 상황에서, i386 아키텍처를 같는 libgcj 패키지 설치는 어떻게 하는게 좋을까요?
libgcj-4.1.2-55.el5.i386.rpm 을 받아서 설치하려니, 종속관계 때문인지 설치가 안되네요.
이렇게 된 상황에서, 하나하나 복구가 어렵다 생각되어서 질문 드리게 됩니다.

CentOS 설치 CD(5.4 x86_64 비트용)를 재설치하면 되는 걸까요?

CentOS를 재설치 하는 방법이 어떻게 되나요?
루트 파티션을 지우고 다시 설치해야 하나요?
그냥 설치 CD 넣고 다시 재설치 하면 되나요?
yum으로 특정버전으로 재설치하는 것이 가능할까요?(혹은 업그레이드 방법으로 재설치?)

좀 다른 질문입니다만, 64비트 CentOS에서 i386 버젼 라이브러리를 사용하는 것은 원래 문제는 없는 건가요?
CentOS 64비트 버전의 설치 CD에 i386으로 된 라이브러리도 포함되어 있을 수 있나요?


추가적인 질문. 
(오라클이 정상 설치된 서버는 CentOS 5 이고, 새로 설치하려다 안되는 서버는 CentOS 6 인 것 같네요)
CentOS 6가 설치되어 있는 서버를
CentOS 5로 다운그레이드 하기위해서는 어떻게 해야 하나요?
루트 파티션을 지우고 다시 설치하는 방법밖에 없을까요?

관련자료

댓글 1

dslee님의 댓글

  • dslee
  • 작성일
센트 6.4 64bit 버전입니다.
그리고 i386은 32bit 이기 때문에 설치가 안되는것 같은데요?
x86 버전을 구하셔서 설치하셔야 될것 같네요.

그리고 센트5 랑 6이랑 변화가 좀 있기 때문에, 호환성 이 맞지 않는 부분이 있고, 5에서는 되던 프로그램이
6에서는 안되요. 때문에 동일한 os를 설치하는게 좋겠네요.

공지사항


뉴스광장


  • 현재 회원수 :  60,081 명
  • 현재 강좌수 :  36,019 개
  • 현재 접속자 :  276 명