질문&답변
클라우드/리눅스에 관한 질문과 답변을 주고 받는 곳입니다.
리눅스 분류

CentOS 5.4 한글 입력 방법

작성자 정보

  • rania 작성
  • 작성일

컨텐츠 정보

본문

혹시 아시는 분 없나요?

글 쓸때마다 엑스피로 다시 부팅해서 써고 있다는 ㅡㅡㅋ
뭐 VMware로 가상으로 엑스피 부팅해서 쓸 수 있겠지만 ㅡㅡㅋ
그렇게 하자니  내 엑스피 하드가 울거 같기도 하고 ㅜㅜ 그러다 보면 부팅할 일이 없으니 에효

여러분  리눅스에서 한글 쓰는 방법 좀 알려주세요 ㅜㅜ

관련자료

댓글 3

로군님의 댓글

  • 로군
  • 작성일
안녕하세요? 초짜 초보자 도우미 로군 입니다 =]

CentO/S 설치시 영문으로 설치 하셨나요? ^^? 

영문 리눅스 환경에서 한글 입력 환경 구성법을 알려 드리겠습니다 ^^

먼저 터미널에서 scim 패키지를 설치 합니다. ^^

#yum install scim
#yum install scim-hangul

다음은, x윈도 에서 키보드 레이아웃을 설정 합니다.
시스템[system] - 관리[preferences] - 키보드[keyboard] 를 클릭 합니다.

Layout 탭 - add 클릭 - korea,Republic of 를 추가 하시고

korea,republic of 옆에 디폴트 체크를 해주세요 ^^

그리고 scim 에서 한글 입력 방법을 설정 합니다.

[시스템]System - [관리]Preferences - [SCIM] SCIM Input Method Setup

Global Setup - Next input method - ... 버튼 클릭
Select the next input method keys 창이 뜨면 - ... 버튼 클릭
Grabbing key 화면이 뜨면 키보드의 한/영 키를 누릅니다.

그러면 Hangul이라는 키가 캡춰되는데, 이를 Add 버튼을 눌러 추가합니다.
(Hangul키가 캡춰되지 않는다면, 키보드 레이아웃 설정이 제대로 되지 않은 것이니 2번 과정을 다시 진행하세요)

그리고 텍스트 입력창에서 한/영키가 제대로 동작하는지 확인 해보시기 바랍니다 ^^'

그래도 안되면 한글 폰트가 없는 경우 라고 짐작되는데 그땐

#yum install kde-i18n-Korean
#yum istall fonts-korean

해서 한글 폰트를 설치 해보세요!

해결에 도움이 됐으면 좋겠네요 =]

rania님의 댓글

  • rania
  • 작성일
한글버전으로 깔았구요
그런데 Grabbing Key 한영키 캡쳐가 안되네요. 히히
일단 그래도 아쉬운대로 설정해서 한글 잘 입력 됩니다.

아 너무 감사합니다..

포도나무님의 댓글

  • 포도나무
  • 작성일
이건 저도 궁금해 하고 있던 방법있던 월욜날 회사 가서 제 리눅스박스에다가 한번 해 봐야겠네요. 감사합니다. ^^

공지사항


뉴스광장


  • 현재 회원수 :  60,091 명
  • 현재 강좌수 :  36,055 개
  • 현재 접속자 :  244 명