질문&답변
클라우드/리눅스에 관한 질문과 답변을 주고 받는 곳입니다.
리눅스 분류

멀티부팅시 eth0 인식에 대한 문제점과, network 설정

작성자 정보

  • 정대규 작성
  • 작성일

컨텐츠 정보

본문

이 놈의 리눅스 ㅡ,.ㅡ;; 왜 이렇게 말을 안 듣는지 모르겠습니다. 정말 죽겠네요.
자세한 사항을 남겨 놓을테니 읽어보시고 좀 도와주세요 흑..

현재 사용중인 서버컴퓨터의 사양입니다.
CPU : 2.4 intel conroe
M/M : 4GB
HDD : 320GB * 2
공유기를 이용한 네트워크 이용중

다음과 같은 설치를 했는데, eth0가 잡히지 않는 경우입니다.

01. 컴퓨터를 처음 구입후 바로 linux를 설치했었습니다. 이것 저것 많이도 깔아봤고
그 중에서 최종은 fedora 7이었습니다. 리눅스를 설치하는 과정에서 network 설정은 억지로 DHCP로 했었습니다. 이유는 리눅스의 설치 완료 후에, ifconfig 명령어와 route 명령어, 그리고 network 설정 파일을 통해서 수동으로 network를 설정하는 작업을 해보고 싶었기 때문입니다.

fedora 7을 최종 설치후 바로 웹브라우저인 firefox를 통해서 java.sun.com에서 jdk1.6을 다운받아서 설치까지 해봤습니다. 결국 인터넷은 이상없이 잘 돌았던 것입니다. 특별히 ifconfig를 통해서 network의 상황을 체크하진 않았던 상태였습니다.

02. 이후에 멀티부팅을 시도하기 위해서 리눅스를 삭제 후, xp pro를 먼저 primary master에 설치를 했습니다. C는 30GB D는 30GB 나머지는 파티션을 설정하지 않은 채로 말이죠.

그 다음에 리눅스를 primary slave에 설치했습니다.

여기에서 문제가 생기기 시작한것입니다.
분명히 xp는 게임도 잘되고, 인터넷도 원할이 되고, 메신저도 잘 돌아갔습니다.
하지만 멀티로 리눅스를 설치후 리눅스만 인터넷이 되지 않는 것입니다.
원인을 파악해보려고도 해봤고 설정도 해봤습니다. 해답이 나오지 않더라구요.

03. 공유기를 이용하고 있기에 다른 xp 노트북의 ip를 먼저 체크해보았습니다.
다른 xp 노트북 ip 자동 설정 상태
ip : 192.168.10.103
netmask : 255.255.255.0
gw : 192.168.10.1

04. 멀티부팅하는 서버컴퓨터의 xp ip를 체크해보았습니다.
멀티부팅 서버컴퓨터의 xp의 ip 자동 설정 상태
ip : 192.168.10.102
netmask : 255.255.255.0
gw : 192.168.10.1

05. 멀티부팅을 하는 컴퓨터의 리눅스에서 문제점을 나열해보겠습니다.

--> 먼저 부팅 중간에 케이블이 연결되지 않은것 같다는 메세지와 함께 점검을 필요로 한다고 나왔습니다.
--> 부팅 이후에 웹브라우저로 여러 사이트의 주소를 쳐봐도 열리지 않았습니다.
--> fconfig를 쳐봤을 때 lo만 잡히고 eth0가 잡히지 않았습니다.

06.
문제를 해결하기 위해 시도한 network 설정 과정을 적어보겠습니다.
># ifconfig eth0 192.168.10.102 netmask 255.255.255.0 broadcast 192.168.10.255 up
이렇게 해서 먼저 eth0를 ip, subnetmask, broadcast를 할당하고 up 시켰습니다.

># route add default gw 192.168.10.1 dev eth0
이렇게 해서 기본 게이트웨이를 설정했습니다.

># vi /etc/resolv.conf
nameserver 168.126.63.1
nameserver 168.126.63.2

이와 같이 DNS를 설정하고 저장했습니다. 바로 컴퓨터를 재부팅했습니다.

07. 재부팅 과정에서 케이블 연결에 대한 메세지는 없었습니다.
하지만 역시나 인터넷은 시도가 되지 않았습니다.
># vi /etc/sysconfig/network-scripts/ifcfg-eth0
내부의 내용을 다음과 같이 수정하고 저장했습니다.
DEVICE=eth0
BOOTPROTO=static
ONBOOT=yes
TYPE=ethernet
USERCTL=no
PEERDNS=no
NETMASK=255.255.255.0
IPADDR=192.168.10.102
GATEWAY=192.168.10.1
HWADDR=00:1a:4d:48:ee:2f


다시 리눅스를 재부팅후 인터넷 역시 되지 않았습니다. xp는 여전히 잘 되고 있었습니다.
늦게 올리는 글이지만 리눅스의 ip는 공유기와 물려있는 사설아이피를 설정했고, 멀티부팅하는 xp의 ip값과 동일하게 입력했습니다.

여기까지 제가 아는 모든 과정을 나열해봤습니다.
조금 보기 번잡스럽더라도, 읽어보시고 혹시 이에 대해 아는 내용이나, 부족한 부분이 있으면 답변 좀 부탁드립니다.
급한 것도 아니지만, 안되니까 속이 터져 죽겠네요;;
많은 댓글 부탁드립니다.

관련자료

댓글 2

박씨네님의 댓글

  • 박씨네
  • 작성일
음..자세히는 잘 모르겠지만 우선, 님의 설명에 논리적으로 오류가 있는 것 같습니다.
분명, 처음에는 dhcp 방식으로 리눅스에서 인터넷 접속이 가능하다 했는데,
뒤에 설명(환결 설정 등)은 마스커레이딩 방식의 설명이군요...

dhcp 방식으로 성공하셨다면, 공유기가 ip를 dhcp 방식으로, 자동으로 뿌려주는 것 같은데......
일단, dhcp 방식으로 환경 설정을 바꾼후 리부팅, 그리고 인터넷 접속을 해보세요...

윈도우에서도 ip를 강제로 할당하셨나요? 아니면 그냥 자동으로 받도록 설정하였나요?
먼저, 윈도우 환경 설정을 확인해보면 빠르겠네요...

정대규님의 댓글

  • 정대규
  • 작성일
먼저 답변 정말 감사드립니다.
위에 제가 좀 자세한 설명을 못했나보네요. xp가 설치된 컴퓨터는 공유기를 이용할 경우 일반적으로는 ip가 자동설정 사설ip로 다 잡히자나요.
A라는 자동설정 사설ip xp노트북과
B라는 멀티부팅 고정 사설ip 리눅스서버(xp는 자동설정 사설ip)가 있는 셈이죠.

분명한건 리눅스만 설치해서 DHCP였을때는 웹브라우저가 가동이 잘 되었었고,
멀티부팅 이후에 리눅스에서 랜카드를 인식을 하지 못하는거 같습니다.
DHCP로 바꿔도 랜카드를 인식못하니 역시 인터넷이 안되는거 같더라구요. 물론 직접 환경설정을 바꿔서 모두 다 시도를 해봤습니다.

혹시나 os탓인가해서 어제 fedora 7을 ubuntu 7.04로 다시 설치해봤지만 역시 마찬가지 였습니다.

혹시 생각나는 부분 있으시면 언제라도 댓글 좀 부탁드리겠습니다.

공지사항


뉴스광장


  • 현재 회원수 :  60,032 명
  • 현재 강좌수 :  35,777 개
  • 현재 접속자 :  66 명