질문&답변
클라우드/리눅스에 관한 질문과 답변을 주고 받는 곳입니다.
리눅스 분류

[재질문~]부팅시 swap 파티션에서 Failed 메시지가..나옵니다.

작성자 정보

  • 황순혁 작성
  • 작성일

컨텐츠 정보

본문

버젼 : 레드헷8   (linux 2.4.18-14smp #1 SMP Wed Sep 4 EDT 2002 i686 i686 i386 GNU/Linux)

리눅스를 재부팅 한 후에.. 데몬들이 올라오는 것을 지켜보구 있었는데..

'swap'파티션 부분에서 Failed가 나는 것을 보았습니다.

그래서 로그파일을 살펴보니..

Jan  2 10:30:45 localhost kernel: kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Jan  2 10:30:29 localhost rc.sysinit: Activating swap partitions:  failed
Jan  2 10:30:48 localhost kernel: ohci1394: pci_module_init failed

위와 같은 로그가 남아 있었습니다..

그리고 파일시스템의 상태는..

[root@localhost root]# df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda2             35175112   5214272  28174012  16% /
/dev/sda1               101089     15072     80798  16% /boot
none                    515248         0    515248   0% /dev/shm

 

[root@localhost root]# fdisk -l

Disk /dev/sda: 255 heads, 63 sectors, 4462 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1        13    104391   83  Linux
/dev/sda2            14      4462  35736592+  83  Linux

Disk /dev/sdb: 255 heads, 63 sectors, 4462 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdb1   *         1       254   2040223+  82  Linux swap
/dev/sdb2           255      4462  33800760    5  Extended

왜 swap영역이 활성화 되지 않았는지 알고 싶습니다..(_ _)> 조언 부탁드립니다..


 

 

 

관련자료

댓글 2

배경수님의 댓글

  • 배경수
  • 작성일
혹시 fstab에 등록된 내용중에 swap부분의 경로가 /dev/sdb1로 정확하게 되어있는지 확인해보시구요. 부팅할때 swap파티션을 마운트 하지 못해서 나오는 현상으로 보여지거든요.. 참고하세요..

황순혁님의 댓글

  • 황순혁
  • 작성일
fstab에도 제대로 설정이 되어 있습니다...-0-;; /dev/sdb1..

공지사항


뉴스광장


  • 현재 회원수 :  60,088 명
  • 현재 강좌수 :  36,051 개
  • 현재 접속자 :  237 명