japanese site
온라인강좌책메일다운로드동아리쇼핑기술지원기업정보갤러리동영상 블로그
『신개념 4단계 리눅스기술지원 시스템 공개』

※ 『무료 리눅스 배포판 배송서비스』 ※

 
라우터 개념, 프로토콜, 종류, 초기설치 방법
조회 : 8,890  


라우터는 전용회선을 통해 LAN에 접속된 여러 시스템(PC, Workstation, Host등)들이 동시에 인터넷을 사용할 수 있도록 하는 장비로서 목적지까지 데이터가 전달될 수 있도록 하는 기능을 하며, 2개 이상의 네트워크를 접속할 때에 사용하고, 상호간의 데이타를 중계한다.

그리고 라우팅 정보를 참조하여 경로를 결정해서 데이타를 중계하며 서로 다른 네트워크를 연결해 주는 장비라고 할수 있다.

대부분의 라우터는 IP 라우팅 기능뿐 아니라 LAN용 프로토콜인 IPX, AppleTalk등의 브리징 기능도 함께 제공한다. 라우터를 취급하는 대표적인 업체로는 CISCO, 3COM, BAY NETWORK, IBM등이 있다.

라우팅이란 패킷을 목적지에 전달하기 위해서 경로정보를 어느 노드에 전달 하는가를 각 노드가 판단할 수 있게 하고 그정보에 따라서 패킷을 전달하게 하는 기능을 한다.

라우터들은 패킷을 목적지까지 전달하기 위해서 인접한 라우터 사이에서 경로정보를 주고 받는데, 이때의 경로정보를 작성하고 제어하는 프로토콜을 라우팅 프로토콜이라 한다. 패킷 스위칭 시스템에서 라우팅은 패킷들을 전송하기 위해서 최적의 경로를 선택하는 과정이라고 할 수 있다.

라우팅되는 네트워크 그룹의 범위에 따라, AS내에서의 라우팅 프로토콜인 IGP와 AS사이에서의 라우팅 프로토콜인 EGP로 나눌 수 있다.

AS(Autonomous System) : 라우팅을 위해서 자율적으로 관리 할 수 있는 네트워크 그룹과 게이트웨이를 AS라고 한다. AS는 내부 라우팅 구성을 자유롭게 할 수 있고, 모든 AS의 네트워크 정보를 수집하고 다른 AS의 네트워크 정보를 통과 시킬 하나 이상의 게이트웨이를 지정해야 한다.

  • IGP(Internal Gateway Protocol) : 여러 네트워크 그룹 중에서 같은 그룹 내에서 경로 정보를 교환하여 통신을 하는 라우팅 프로토콜
    예)RIP, OSPF, IGRP등

  • EGP (External Gateway Protocol) : 네트웍이 다른, 그룹 사이에서 경로정보를 교환하여 통신을 하는 프로토콜
    예)BGP등

RIP(Routing Infomation Protocol)

RIP는 인테리어 라우팅 프로토콜로서, 현재 가장 널리 사용되어지는 프로토콜 중 하나이며, 네트워크 구성상 계층은 없고 평면적이다. RIP에서 사용하는 Metric을 Hop Count(홉수)라고 한다. RIP에서는 도달할 목적지의 거리(길이의 개념이 아니고 몇개의 Gateway를 거치는가의 개념)를 측정하기 위해서 홉수를 사용한다. 어떤 인테페이스에 직접 연결되어 있을때 홉수는 0이며, RIP로 통신을 할 수 있는 최대의 홉수는 15이다. 상대방 네트워크 까지의 홉수가 16을 초과 할 때는 통신을 할 수가 없다.

RIP는 Distance Vector 방식을 채용하고 있는 대표적인 프로토콜로서 각각의 라우터가, 인접하고 있는 라우터와 라우팅 정보를 주기적으로 교환하여 라우팅 하도록 하는 방법이다. 인접한 라우터로부터 받은 정보는 매30초마다 라우터의 각 인터페이스로 라우팅정보를 전달하며, 이 정보는 각 라우터에서 동작할때 사용하게 된다.

Distance Vector 알고리즘


각각의 라우터는 일정한 주기로 인접한 라우터로 라우팅 정보를 흘려 보낸다. 라우팅 정보의 변화가 없을 때에도 라우터는 Update된 정보를 흘려 보낸다.

RIP PROTOCOL의 Setting 방법

각기 다른 네트워크를 사용하는 라우터 A와 B는 Serial 0을 통해서, RIP를 활성화하여 서로의 네트워크 정보를 교환함으로써 통신을 가능하게 한다.

ROUTER A#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
ROUTER A#(config)#router rip
ROUTER A#(config-router)# network 130.10.0.0
ROUTER A#(config-router)# ^Z
ROUTER A#write
Building configuration...
[OK]
interface serial 0
ip address 130.10.62.1 255.255.255.0
interface ethernet 0
ip address 130.10.8.1 255.255.255.0
router rip
network 130.10.0.0
ROUTER B# config terminal
Enter configuration commands, one per line. End with CNTL/Z.
ROUTER B#(config)#router rip
ROUTER B#(config-router)# network 130.10.0.0
ROUTER B#(config-router)# ^Z
ROUTER B#write
Building configuration...
[OK]
interface serial 0
ip address 130.10.62.2 255.255.255.0
interface ethnet 0
ip address 130.10.17.2 255.255.255.0
router rip
network 130.10.0.0

OSPF(Open Shortest Path Fast)

OSPF의 라우팅 환경은 Area와 AS라는 두가지의 중요한 요소를 가지고 계층적으로 구성된다. Area는 인접한 OSPF 네트워크와 호스트들의 집합이고, 각 Area들은 OSPF Autonomous System에 의해 논리적으로 나누어 진다.

AS는 OSPF 인터네트워크에서 가장 큰 개체이고, 같은 라우팅 방법을 가지고 있는 네트워크들의 집합이다.이러한 계층적인 구성은 라우팅 테이블을 감소시켜 트래픽을 줄일 수 있고, 라우팅 경로 선택에 있어서 효과적으로 가장 짧은 경로를 선택할 수 있다.

OSPF는 Link State 방식을 사용하는 인테리어 라우팅 프로토콜이다.

라우터는 인접한 라우터로 라우터의 모든 경로정보를 보내는 것이 아니라 각 라우터의 고유의 접속정보만 흘려 보낸다.접속정보를 받은 후에 각 라우터는 자신의 라우팅 테이블을 가지고 최적의 경로를 설정한다.

OSPF는 RIP에 비해 홉수에 제한이 없고, Convergence 시간이 빠르다.(Convergence시간 : 라우터의 연결이 다운되는 등의 라우터의 변화가 생겼을 때 회복되는 시간)

OSPF는 RIP와 같이 라우팅 정보를 주기적이 아닌 변화가 있을 때에만 갱신함으로써 대역을 효과적으로 사용할 수 있고, 동일한 네트워크 어드레스에서 VLSM(Variable Length Subnet Mask)를 사용하여 한정된 어드레스를 효율적으로 이용할 수 있다.(VLSM: 어떤 Class내의 하나의 IP 어드레스를 여러개의 네트워크로 쪼개어 다양한 크기로 사용할 수 있다.)

Link State 알고리즘

각각의 라우터는 각 인터페이스의 정보를 포함한 접속정보를 생성, 유지하여 한 AS내의 모든 라우터에게 접속정보를 전달한다. 그 결과 라우터들은 고유의 데이타베이스를 작성하여 가지게 된다. 모든 라우터는 최단경로 알고리즘으로 동작하고, 접속정보를 기초로 하여 최단 경로를 설정할 수 있다.

이러한 OSPF의 많은 장점으로 인하여 대부분의 라우터 밴더들은 OSPF를 지원 할 것이고, 점차 RIP에서 OSPF로 전환하는 추세이며 많은 네트워크 구성에 있어서 RIP를 대신 할 것이다.

OSPF PROTOCOL의 Setting 방법

RTA,RTB,RTC,RTD는 Area 0.0.0.0 에서 동일한 Ethernet에 연결되어 있고 RTA는 Area 1에도 연결되어 있다. RTA와 RTB는 Process-id 10을 가지고 OSPF로 통신을 한다. 다음은 RTA와 RTB에 대한 셋팅값이며, RTC와 RTD도 RTB와 비슷하게 설정된다.

RTA# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RTA# (config)#router ospf 10
RTA#( config-router)#network 203.250.13.1 0.0.0.0 area 1
RTA#(config-router)#network 203.250.0.0 0.0.255.255 area 0.0.0.0
RTA#(config-router)# ^Z
RTA#wr
Building configuration...
[OK]
hostname RTA
interface loopback 0
ip address 203.250.13.41 255.255.255.0
interface ethernet 0
ip address 203.250.14.1 255.255.255.0
router ospf 10
network 203.250.13.1 0.0.0.0 area 1
network 203.250.0.0 0.0.255.255 area 0.0.0.0
RTB# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RTB# (config)#router ospf 10
RTB#(config-router)# network 203.250.0.0 0.0.255.255 area 0.0.0.0
RTB#(config-router)# ^Z
RTB#wr
Building configuration...
[OK]
hostname RTB
interface ethernet 0
ip address 203.250.14.2 255.255.255.0
router ospf 10
network 203.250.0.0 0.0.255.255 area 0.0.0.0

BGP(Border Gateway Protocol)

BGP는 AS 사이에서 통신을 하는 익스테리어 라우팅 프로토콜이다. BGP는 다른 BGP시스템과 신뢰성 있는 정보를 교환하고, 이 정보에는 전송되어 서로 통신하게 될 AS내의 모든 경로가 포함되어 있다. AS사이에서 통신하는 EBGP(External BGP)와 동일 AS내에서 통신을 하는 IBGP(Internal BGP)가 있다.

BGP는 Distance Vector 알고리즘으로 동작하지만 RIP와는 달리 주기적으로 정보 교환을 하지 않고 변화가 있을 때에만 정보를 교환한다.

BGP는 인접한 라우터에게 Keepalive 메세지를 보냄으로써 TCP 연결이 끊어 졌다는 것을 인식하며, Keepalive 메세지의 권고값은 30초이다.

BGP는 주로 별도의 AS를 가진 ISP(Internet Service Provider)사이의 통신에 주로 이용된다.

IBGP는 각 라우터끼리 MESH 형태로 연결되어 있지 않으면, 라우팅 정보를 주고 받지 못한다.R1은 R2,R3의 라우팅 정보를 받을 수 있으나 R2로 보내지는 않는다. NETWORK A에 대해서 R3는 R1으로 부터 라우팅 정보가 BGP로는 들어 오지만 IBGP로 들어오기 전까지는 R4로 라우팅 정보를 흘려 보내지 않는다.이것을 Synchronization이라고 한다.

BGP PROTOCOL의 Setting 방법

각기 다른 AS 를 가진 RTA와 RTB가 TCP 연결을 하여 BGP로 라우팅 정보를 주고 받는다.

RTA# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RTA# (config)#router bgp 100
RTA# (config-router)# network 19.0.0.0
RTA#(config-router)# neighbor 15.1.1.2 remote-as 200
RTA#(config-router)# ^Z
RTA#wr
Building configuration...
[OK]
router bgp 100
network 19.0.0.0
neighbor 15.1.1.2 remote-as 200
RTB# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RTB# (config)#router bgp 200
RTB# (config-router)#network 15.0.0.0
RTB#(config-router)# neighbor 15.1.1.1 remote-as 100
RTB#(config-router)# ^Z
RTB#wr
Building configuration...
[OK]
router bgp 200
network 15.0.0.0
neighbor 15.1.1.1 remote-as 100


Static 라우팅
라우터상에서 관리자가 수동적인 방법으로 라우팅 테이블을 관리하는 방법이다.

RTA에서 RTB(131.108.1.0)의 라우팅 테이블을 131.108.2.1로 강제로 보내게 설정을 할 수 있다.

Dynamic 라우팅
각각의 인접한 라우터들 사이에서 네트워크 정보를 교환하고, 라우팅 테이블을 자동적으로 작성한다.이 때 라우터들 사이에서 라우팅 테이블을 작성하고제어하는 절차를 규정하고 있는 것이 라우팅 프로토콜이 된다. RIP나 OSPF등이 여기에 속한다.

RIP를 활성화함으로써 RTA의 경로정보가 각 라우터로 교환이 되고,라우팅 테이블이 자동적으로 생성된다.

Default 라우팅
라우터에서 패킷을 수신하면,라우팅 테이블상에 상대방 네트워크 IP 어드레스를 검색하여 패킷을 어디로 보낼 것인가를 결정하는데, 라우터에 Default Route가 설정이 되어 있으면, 라우팅 테이블상에서 등록되어 있지 않는 모든 정보들이 지정된 경로로 전송된다.

CUSTOMER쪽 라우터에서 아이네트쪽 네트워크를 라우팅 테이블에서 찾아보고 등록이 되어 있지 않으면,패킷을 파기하고 디폴트가 설정이 되어 있으면 203.248.43.5로 갈 수 있게 보낸다.


앞에서 라우터에 관해서 간략히 알아 보았는데 라우터를 가지고 최적의 네트워크를 구성하기 위해서는 자사 네트워크의 규모나 특성등을 정확히 파악하여 구축하는 것이 바람직 할 것 같다.

전용회선 구성이 완료되면 라우터를 종단장치와 연결을 하여 초기 셋팅을 한다. 국내에 가장많이 보급된 CISCO 라우터는 초기 셋팅의 편의를 위해 "SETUP"이라는 Command를 제공한다.다음은 라우터로 Access하는 방법과 SETUP명령을 통해 실제로 셋팅하는 방법이다.처음 라우터를 구입하게 되면 각종 라우터 비품과 MANNUAL이 있는데 자세한 내용은 이를 참조한다.

CISCO ACCESS 방법

CONSOLE
CONSOLE 케이블과 단말기(PC,NOTE-BOOK)를 사용하여 직접 연결 장비와 함께 제공되는 CONSOLE 케이블을 이용한다.

통신 포트 셋팅: 9600-NONE-8-1
속도: 9600
흐름제어: XON/OFF
패리티 비트: 8BIT
STOP BIT: 1BTT

TELNET
TELNET을 이용하여 원격으로 ACCESS 하는 방법 LAN에 연결되어 있는 환경에서는 TELNTE 에뮬레이터를 이용하여 접근

AUX
AUX PORT를 이용하여 원거리에서 ACCESS하는 방법 많이 사용하지는 않지만, aux port에 모뎀을 연결하여 원거리 지역에서 전화를 걸어서 접속하는 방법이 있다.


SETUP 방법
setup command를 이용한 설정(대화형식의 라우터 설정)

예) Router#setup

--- System Configuration Dialog ---
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Continue with configuration dialog? [yes]: - 대화형식의 환경설정

First, would you like to see the current interface summary? [yes]:

Interface IP-Address OK? Method Status Protocol

Ethernet0 203.255.112.228 YES NVRAM up up

Serial0 203.231.85.138 YES manual down down

Configuring global parameters:

Enter host name [Router]: router - 라우터의 명칭

The enable secret is a one-way cryptographic secret used
instead of the enable password when it exists.
Enter enable secret []: router - enable password(암호화된 형태)
enable password 보다 우선

The enable password is used when there is no enable secret
and when using older software and some boot images.

Enter enable password [router]: router - enable password(일반text 형태)

Enter virtual terminal password [router]: router - 외부에서 접속할 때 묻는 password

Configure SNMP Network Management? [yes]: - NMS를 정의

Community string [public]: - SNMP community 설정

Configure IP? [yes]: - ip address 설정

Configure IGRP routing? [no]:- IGRP 프로토콜 사용 안함

Configure RIP routing? [yes]: - RIP 프로토콜 사용

Configuring interface parameters:

Configuring interface Ethernet0:

Is this interface in use? [yes]: - ethnet 인터페이스 사용

Configure IP on this interface? [yes]: - ip address 설정함

IP address for this interface [203.255.112.228]: - 사용할 ip address 기입

Number of bits in subnet field [0]: - subnet 비트 수(0은 디폴트)

Class C network is 203.255.112.0, 0 subnet bits; mask is /24

Configuring interface Serial0:

Is this interface in use? [yes]: - serial 인터페이스 사용

Configure IP on this interface? [yes]: - ip address 설정함

Configure IP unnumbered on this interface? [no]: - ip address 설정함

IP address for this interface [203.231.85.138]: - 사용 할 ip address 기입

Number of bits in subnet field [6]: - 6비트로 subnet

Class C network is 203.231.85.0, 6 subnet bits; mask is /30

The following configuration command script was created:

hostname router

enable secret 5 $1$msJM$TvuEk.ljvlRD98LBHb5ya/

enable password router

line vty 0 4

password router!

ip routing

!

interface Ethernet0

ip address 203.255.112.228 255.255.255.0

!

interface Serial0

ip address 203.231.85.138 255.255.255.252

!

router rip

network 203.255.112.0

network 203.231.85.0

!

end

Use this configuration? [yes/no]: y - 환경 설정 사용함

The enable secret you have chosen is the same as your enable password.

This is not recommended. Re-enter the enable secret.

The enable password you have chosen is the same as your enable secret.

This is not recommended. Re-enter the enable password.

Building configuration...

[OK]

Use the enabled mode 'configure' command to modify this configuration.

router#




Copyright(c) PSINet Korea Inc. All right reserved. inoc@kr.psi.net

[원글링크] : https://www.linux.co.kr/home2/board/subbs/board.php?bo_table=lecture&wr_id=886


이 글을 트위터로 보내기 이 글을 페이스북으로 보내기 이 글을 미투데이로 보내기

 
(주) 수퍼유저

 
   
 


『신개념 4단계 리눅스기술지원 시스템 공개』

CentOS 리눅스 전문서적 국내최초출시

 
회사소개 | 보도기사 | 채용안내 | 광고안내 | 이용약관 | 개인정보취급방침 | 책임한계와 법적고지 | 불편사항 신고하기 | 사이트맵
ㅇ 서울 : 서울특별시 강남구 노현로79길 66, 402호(역삼동,청송빌딩)  ㅇ 부산 : 부산광역시 해운대구 우동 1470 에이스하이테크21 914호
ㅇ 대표 : 1544-8128 ㅇ부산직통 : 051-744-0077 ㅇ서울직통 : 02-856-0055 ㅇ FAX : 02-6280-2663
ㅇ 사업자번호 : 128-86-68239 ㅇ 통신판매업 신고번호 : 2013-부산금정-0035호 ㅇ 개인정보책임자 : 이재석
ㅇ 상호명 : (주) 수퍼유저 ㅇ 대표자 : 박성수
Copyright ⓒ (주)수퍼유저. All rights reserved.

 아 이 디
 비밀번호
회원 가입 | 비밀번호 찾기

블로그~
 
▷ 네트웍
SMS
MRTG
개념및 프로토콜
네트웍 장비
ACL
책제목
리눅스서버관리실무바이블v3.0


저자 박성수
페이지수 2,032 pages
펴낸곳(주)수퍼유저

리눅스 서버 구축 및 관리에 필요한 거의 모든 부분과 전반적인 실무 기법들을 다루고 있음
책제목
리눅스보안관리실무(2/E)


저자홍석범
페이지수 820 pages
펴낸곳(주)수퍼유저

리눅스 보안에 관련된 내용을 종합적으로 쓴 책. 저자의 명성 그대로 보안관련의 모든 내용이 그대로 담겨져 있다.